On Hypernode we want to offer the best experience for e-commerce developers out of the box. We strive to have good defaults so that as a Magento or Shopware developer you can get quickly up and running. For that reason we prevented our default /usr/local/bin/composer installation from self-updating to the 2.0 version by self updating with the --1 flag. The reason for this is backwards compatibility because Magento only started including support for composer 2 in Magento 2.4.2.

In this release we added a new separate installation of composer for convenience. Of course you could install any version of composer you want manually by running:

But to have all the relevant development tools available out of the box we have now also added composer2 in a separate path:

Changes will be deployed on all Hypernodes over the course of the coming week.